OSPFv3 คืออะไร พร้อมตัวอย่างการ Configuration

          OSPFv3 คือ OSPF Routing Versionใหม่ที่สามารถทำการ Routing ได้ทั้ง IPv4 และ IPv6 ซึ่งปัจจุบันหรือที่เราใช้กันมาก่อนหน้านี้จะเป็น OSPFv2(Version2)ที่สามารถ Routing ได้เฉพาะ IPv4 เท่านั้น และ OSPFv3 ก็ไม่สามารถทำงานร่วมกับ OSPFv2 ได้ (ไม่สามารถ Form OSPF Neighbor กันได้

 

สิ่งที่แตกต่างกันระหว่าง OSPFv3 และ OSPFv2 มีอยู่หลายอย่าง เช่น

หมายเหตุ: ผู้อ่านอาจจะต้องมีความเข้าใน OSPFv2 มาก่อน เนื่องจากในบทความนี้จะไม่ได้อธิบายการทำงานของ OSPFv2 แต่จะเน้นไปทาง OSPFv3 อย่างเดียว

 

  • OSPFv3 รองรับ Network Type ทั้งหมด 5 แบบ สิ่งที่เพิ่มมาใหม่จาก OSPFv2 คือ Network Type "manet"

R1(config-if)#ipv6 ospf network ?             
  broadcast            Specify OSPF broadcast multi-access network
  manet                Specify MANET OSPF interface type
  non-broadcast        Specify OSPF NBMA network
  point-to-multipoint  Specify OSPF point-to-multipoint network
  point-to-point       Specify OSPF point-to-point network
R1(config-if)#

ซึ่ง Network Type "manet" ออกแบบมาสำหรับ Mobile Ad Hoc Network

 

  • LSA Type ใหม่ของ OSPFv3 ซึ่งในบทความนี้จะทำการ show ให้เห็น LSA Type 8 และ LSA Type 9 กันครับ

LSA Type 8

Link (Type-8) Link States (Link LSA หรือ LSA Type-8) เป็น LSA Type ใหม่ใน OSPFv3 ซึ่งOSPFv2 จะไม่มี LSA Type นี้ ในตัวอย่างบทความนี้ที่เราจะแสดงตัวอย่างให้เห็นว่าตัว R1 ทำการสร้าง Link LSA Typeนี้เพื่ออธิบาย IPv6 Network/Prefix, สถานะและคุณสมบัติของ Link/Interface ให้แต่ละ Interface ที่ Enable OSPFv3 และทำการ Advertise/Flood ให้กับ R2

LSA Type 9

Intra Area Prefix Link States (Intra-Area Prefix LSA หรือ LSA Type-9) เป็น LSA Type ใหม่ใน OSPFv3 ซึ่ง OSPFv2 จะไม่มี LSA Type นี้ ในตัวอย่างบทความนี้ที่เราจะแสดงตัวอย่างให้เห็นว่าตัว R1 ทำการสร้าง Intra-Area Prefix LSA เพื่ออธิบาย IPv6 Network/Prefix ของ R1, Stub Network (ใน IPv4 Advertise ข้อมูลนี้โดยใช้ Router LSA หรือ LSA Type-1)  และ Transit Network บน R1 (ใน IPv4 Advertise ข้อมูลนี้โดยใช้ Network LSA หรือ LSA Type-2) และทำการ Advertise/Flood ให้กับ R2

 

มาดูตัวอย่างการ Configure OSPFv3 กันครับ

          ตัวอย่างต่อไปนี้เป็นการสาธิตวิธีการ Configure OSPFv3  บน Cisco IOS ซึ่งเป็น Operating System บน Cisco Router Hardware Platform เช่น ISR 1900, 2900, 3900 และ ISR 4000
หมายเหตุ (RIPng และการ Configure IPv6 Route Redistribution ระหว่าง OSPFv3 และ RIPng Routing Domain จะขอกล่าวในบทความต่อไป)

การสาธิตในครั้งนี้ใช้ EVE-NG ในการสร้าง IPv6 Routing Lab และใช้ IOS Version 15.5 ถ้าหากท่านไหนจะศึกษาเพิ่มเติมในส่วนของโปรแกรมนี้ ลองเข้าไปดูในเวบนี้นะครับ http://www.eve-ng.net/

 

ทำการ Configure IPv6 Address บน Interface Loopback0 และ Ethernet 0/0 บน R1 ตาม Network Diagram

R1>enable
R1#
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#


Interface Loopback0 ใช้ IPv6 Prefix Length ขนาด 128 Bits และการ Configure IPv6 Address บน Interface จะแตกต่างจากการ Configure IPv4 Address โดย IPv4 ใช้ Subnet Mask (ตัวอย่าง Subnet Mask ของ IPv4 255.255.255.0 )

R1(config)#int lo0
R1(config-if)#ipv6 address 2001:1:0:1::1/128
*Sep  6 16:33:06.333: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#
R1(config-if)#
R1(config-if)#int e0/0
R1(config-if)#ipv6 address 2001:1:0:12::1/64
R1(config-if)#no shut
R1(config-if)#
*Sep  6 16:33:27.000: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Sep  6 16:33:28.008: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
R1(config-if)#              
R1(config-if)# 

 

Check IPv6 Address Configure บน Interface ของ R1 ด้วย “do show run” Command สังเกตว่าใช้ “do” นำหน้า “show run” เนื่องจากอยู่ใน Interface Configuration Mode เวลาใช้ Command ที่อยู่ใน Exec Mode ต้องใช้ “do” นำหน้า

 R1(config-if)#do sh run
Building configuration...

interface Loopback0
 no ip address
 ipv6 address 2001:1:0:1::1/128
!
interface Ethernet0/0
 no ip address
 ipv6 address 2001:1:0:12::1/64
!

 

Configure IPv6 Address บน Interface Loopback0, Ethernet 0/0 และ Ethernet 0/1 บน R2 ตาม Network Diagram

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#
R2(config)#int lo0
R2(config-if)#ipv6 address 2001:1:0:2::2/128
*Sep  6 16:43:22.186: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#
R2(config-if)#
R2(config-if)#int e0/0
R2(config-if)#ipv6 address 2001:1:0:12::2/64
R2(config-if)#no shut
R2(config-if)#
R2(config-if)#
*Sep  6 16:45:41.933: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Sep  6 16:45:42.940: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
R2(config-if)#
R2(config-if)#
R2(config-if)#int e0/1                      
R2(config-if)#ipv6 address 2001:1:0:23::2/64
R2(config-if)#no shut
R2(config-if)#
*Sep  6 16:52:08.243: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
*Sep  6 16:52:09.249: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
R2(config-if)#
R2(config-if)#

 

Check IPv6 Address Configure บน Interface ของ R2 ด้วย “do show run” Command

 R2(config-if)#do sh run
Building configuration...

interface Loopback0
 no ip address
 ipv6 address 2001:1:0:2::2/64
!
interface Ethernet0/0
 no ip address
 ipv6 address 2001:1:0:12::2/64
!
interface Ethernet0/1
 no ip address
 ipv6 address 2001:1:0:23::2/64
!

R2(config-if)#



Configure IPv6 Address บน Interface Loopback0 และ Ethernet 0/1 บน R3 ตาม Network Diagram

หมายเหตุ: ในบทความนี้จะไม่ได้กล่าวถึง R3 เนื่องจากใน Diagram จะไม่เกี่ยวข้องกับ OSPFv3 เพียงแค่ต้องการแสดงให้เห็นถึงการตั้งค่า IPv6 บน Interface เท่านั้น

R3>enable
R3#
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#
R3(config)#int lo0
R3(config-if)#ipv6 address 2001:1:0:3::3/128
*Sep  7 02:52:48.322: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#
R3(config-if)#int e0/1
R3(config-if)#ipv6 address 2001:1:0:23::3/64
R3(config-if)#no shut
R3(config-if)#
*Sep  7 02:53:11.905: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
*Sep  7 02:53:12.912: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
R3(config-if)#
R3(config-if)#



Check IPv6 Address Configure บน Interface ของ R3 ด้วย “do show run” Command

 R3(config-if)#do sh run
Building configuration...

interface Loopback0
 no ip address
 ipv6 address 2001:1:0:3::3/128
!
interface Ethernet0/1
 no ip address
 ipv6 address 2001:1:0:23::3/64
!
          
R3(config-if)#


Ping ไปที่ IPv6 Address ของ R2 E0/0 เพื่อ Check IPv6 Reachabiliity ก่อนทำการ Configure IPv6 Unicast Routing สังเกตว่าเราสามารถใช้ “ping” Command แล้วทำการระบุ IPv6 Address ได้เลยหรือใช้ “ping ipv6” Command แล้วตาม IPv6 Address ก็ได้เช่นกันครับ

R1(config-if)#do ping 2001:1:0:12::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:0:12::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1(config-if)#
R1(config-if)#
R1(config-if)#do ping ipv6 2001:1:0:12::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:0:12::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1(config-if)# 



Ping ไปที่ IPv6 Address ของ R1 E0/0 และ R3 E0/1 เพื่อ Check IPv6 Reachabiliity ก่อนทำการ Configure IPv6 Unicast Routing

 R2(config-if)#do ping 2001:1:0:12::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:0:12::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/23 ms
R2(config-if)#
R2(config-if)#
R2(config-if)#do ping 2001:1:0:23::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:0:23::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/19 ms
R2(config-if)#
R2(config-if)#
R2(config-if)#
R2(config-if)#do ping ipv6 2001:1:0:12::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:0:12::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
R2(config-if)#
R2(config-if)#
R2(config-if)#do ping ipv6 2001:1:0:23::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:0:23::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/6 ms
R2(config-if)#


Ping ไปที่ IPv6 Address ของ R2 E0/1 เพื่อ Check IPv6 Reachabiliity ก่อนทำการ Configure IPv6 Unicast Routing

R3(config-if)#do ping 2001:1:0:23::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:0:23::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
R3(config-if)#
R3(config-if)#
R3(config-if)#do ping ipv6 2001:1:0:23::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:0:23::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R3(config-if)#exit



Configure OSPFv3 บน R1


Cisco IOS ใช้ IPv6 CEF (Cisco Express Forwarding) ในการ Routing และ Switching IPv6 Packet เพราะฉะนั้นจำเป็นต้อง Enable IPv6 CEF

R1(config)#ipv6 cef
%Must enable IPv6 routing first
R1(config)#
R1(config)# 


สังเกตว่า Enable IPv6 CEF ไม่ได้ เนื่องจากต้อง Enable IPv6 Unicast-Routing ก่อนถึงจะสามารถ Enable IPv6 CEF

R1(config)#ipv6 unicast-routing
R1(config)#ipv6 cef
R1(config)#
R1(config)# 


OSPFv3 เป็น OSPF Routing ที่สามารถ Routing ได้ทั้ง IPv4 และ IPv6 ซึ่งต่างจาก OSPFv2 ที่ใช้งานกันในปัจจุบันซึ่งสามารถ Routing ได้เฉพาะ IPv4 เท่านั้น และไม่สามารถทำงานร่วมกับ OSPFv3 ได้ (ไม่สามารถ Form OSPF Neighbor กันได้

และสังเกตว่า OSPFv3 เวลา Configure Router-ID ต้องใช้ IPv4 Address Format ได้เท่านั้น

R1(config)#router ospfv3 1
R1(config-router)#router-id ?
  A.B.C.D  OSPF router-id in IP address format

R1(config-router)#router-id 1.1.1.1
R1(config-router)#
R1(config-router)# 


การ Enable OSPFv3 และ Assign Area บน Interface จะแตกต่างกับ OSPFv2 โดย OSPFv3 ใช้การ Enable OSPF ภายใต้ Interface ส่วน OSPFv2 ใช้การ Enable OSPF ภายใต้ “router ospf” Command โดยใช้ “network” แล้วตามด้วย Network Address และ Wildcard Mask (ยกตัวอย่างเช่น “network 192.168.1.0 0.0.0.255 area 0”)

R1(config-router)#int lo0
R1(config-if)#ipv6 ospf 1 area 0
R1(config-if)#
R1(config-if)#
R1(config-if)#int e0/0
R1(config-if)#ipv6 ospf 1 area 0 



OSPFv3 รองรับ Network Type ทั้งหมด 5 แบบนะครับ สิ่งที่แตกต่างจาก OSPFv2 คือ OSPFv3 เพิ่ม Network Type ใหม่ขึ้นมาคือ “manet” ออกแบบมาสำหรับ Mobile Ad Hoc Network

R1(config-if)#ipv6 ospf network ?              
  broadcast            Specify OSPF broadcast multi-access network
  manet                Specify MANET OSPF interface type
  non-broadcast        Specify OSPF NBMA network
  point-to-multipoint  Specify OSPF point-to-multipoint network
  point-to-point       Specify OSPF point-to-point network

R1(config-if)#  



เนื่องจาก R1 และ R2 เชื่อมต่อ Ethernet แบบ Point-to-Point เพราะฉะนั้นเพื่อทำให้ OSPFv3 สามารถ Form OSPF Neighbor ได้รวดเร็วโดยทำการ Bypass ขั้นตอนการเลือก DR/BDR ซึ่งเป็น 1 ในขั้นตอน Form OSPF Neighbor ของ Broadcast Network อย่าง Ethernet

R1(config-if)# ipv6 ospf network point-to-point
R1(config-if)# 


Check OSPFv3 Configure บน R1 ด้วย “do show run” Command

R1(config-if)#do sh run   
Building configuration...
   
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address 2001:1:0:1::1/64
 ipv6 ospf 1 area 0
!
interface Ethernet0/0
 no ip address
 ipv6 address 2001:1:0:12::1/64
 ipv6 ospf 1 area 0
 ipv6 ospf network point-to-point
!
router ospfv3 1
 router-id 1.1.1.1
 !
 address-family ipv6 unicast
 exit-address-family
!

R1(config-if)#exit



Configure OSPFv3 บน R2


Enable IPv6 Unicast Routing และ IPv6 CEF บน R2 ก่อนเริ่ม Configure OSPFv3 บน R2 เนื่องจากทั้งสอง Command เป็น Prerequisite ที่จำเป็นต้องการ Configure IPv6 Unicast Routing บน Cisco IOS

R2(config)#ipv6 unicast-routing
R2(config)#ipv6 cef
R2(config)#
R2(config)# 


Configure OSPFv3 และ Assign Router-ID บน R2

R2(config)#router ospfv3 1
R2(config-router)#router-id 1.1.2.2
R2(config-router)#
R2(config-router)# 


Enable OSPFv3 และ Assign Area 0 บน Interface Loopback0 ของ R2

R2(config-router)#int lo0
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#
R2(config-if)#


Enable OSPFv3 และ Assign Area 0 บน Interface Ethernet0/0 พร้อมทั้ง Configure OSPF Network Type เป็นแบบ “point-to-point” (Ethernet Interface มี OSPF Network Type แบบ “broadcast” โดย Default และทำการเลือก DR/BDR Election โดยอัตโนมัติ) ของ R2

R2(config-if)#int e0/0
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#ipv6 ospf network point-to-point
R2(config-if)# 


มี Syslog แจ้งเตือนให้ทราบว่า R2 สามารถ Form OSPF Neighbor กับ R1 ได้ โดยมีสถานะของ OSPF Neighbor เป็น “Full” ซึ่งเป็นสถานะที่บ่งบอกว่า R2 และ R1สามารถแลกเปลี่ยน OSPF Hello เพื่อ Form OSPF Neighbor และมีการแลกเปลี่ยน LSA เพื่อทำ Database Synchornization กันเสร็จเรียบร้อยแล้ว

*Sep  7 03:13:18.092: %OSPFv3-5-ADJCHG: Process 1, IPv6, Nbr 1.1.1.1 on Ethernet0/0 from 2WAY to DOWN, Neighbor Down: Interface down or detached
*Sep  7 03:13:18.100: %OSPFv3-5-ADJCHG: Process 1, IPv6, Nbr 1.1.1.1 on Ethernet0/0 from LOADING to FULL, Loading Done
R2(config-if)#
R2(config-if)#
R2(config-if)# 


Check OSPFv3 Configure บน R1 ด้วย “do show run” Command

R2(config-if)#do sh run
Building configuration...

ipv6 unicast-routing
ipv6 cef  
!
interface Loopback0
 no ip address
 ipv6 address 2001:1:0:2::2/64
 ipv6 ospf 1 area 0
!
interface Ethernet0/0
 no ip address
 ipv6 address 2001:1:0:12::2/64
 ipv6 ospf 1 area 0
 ipv6 ospf network point-to-point
!
interface Ethernet0/1
 no ip address
 ipv6 address 2001:1:0:23::2/64
!
router ospfv3 1
 router-id 1.1.2.2
 !
 address-family ipv6 unicast
 exit-address-family
!

R2(config-if)# 


Check OSPFv3 Neighbor บน R1 เพื่อ Ensure ว่า R1 สามารถ Form OSPF Neighbor กับ R2 บน Interface E0/0 ได้ สังเกตตรง Column State พบสถานะเป็น “FULL” ซึ่งเป็นสถานะปกติของการ Form OSPF Neighbor และ R1 มี Router-ID: 1.1.1.1 และใช้ Process ID:1 ตามที่ Configure OSPFv3

R1(config-if)#do sh ipv6 ospf neighbor

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
1.1.2.2           0   FULL/  -        00:00:33    3               Ethernet0/0
R1(config-if)#
R1(config-if)# 


Check OSPFv3 Database บน R1 พบ LSA ทั้งหมด 3 แบบ


1.Router Link States หรือ LSA Type 1 นั้นเอง
2.Link (Type-8) Link States (Link LSA หรือ LSA Type-8) เป็น LSA Type ใหม่ใน OSPFv3 ซึ่งOSPFv2 จะไม่มี LSA Type นี้ โดย R1 ทำการสร้าง Link LSA เพื่ออธิบาย IPv6 Network/Prefix, สถานะและคุณสมบัติของ Link/Interface ให้แต่ละ Interface ที่ Enable OSPFv3 และทำการ Advertise/Flood ให้กับ R2
3.Intra Area Prefix Link States (Intra-Area Prefix LSA หรือ LSA Type-9) เป็น LSA Type ใหม่ใน OSPFv3 ซึ่ง OSPFv2 จะไม่มี LSA Type นี้ โดย R1 ทำการสร้าง Intra-Area Prefix LSA เพื่ออธิบาย IPv6 Network/Prefix ของ R1, Stub Network (ใน IPv4 Advertise ข้อมูลนี้โดยใช้ Router LSA หรือ LSA Type-1)  และ Transit Network บน R1 (ใน IPv4 Advertise ข้อมูลนี้โดยใช้ Network LSA หรือ LSA Type-2) และทำการ Advertise/Flood ให้กับ R2

R1(config-if)#do sh ipv6 ospf database

            OSPFv3 Router with ID (1.1.1.1) (Process ID 1)

        Router Link States (Area 0)

ADV Router       Age         Seq#        Fragment ID  Link count  Bits
 1.1.1.1         1145        0x80000002  0            1           None
 1.1.2.2         1146        0x80000002  0            1           None

        Link (Type-8) Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Interface
 1.1.1.1         1429        0x80000001  3          Et0/0
 1.1.2.2         1151        0x80000001  3          Et0/0

        Intra Area Prefix Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID
 1.1.1.1         352         0x80000005  0          0x2001      0
 1.1.2.2         275         0x80000004  0          0x2001      0
R1(config-if)#
R1(config-if)# 


Check IPv6 Routing Table บน R1 พบ OSPF Route ของ R2 Loopback0 (“O” คือ OSPF Intra Area Route ที่อยู่ภายใน Area 0 นั้นเอง) สังเกตครับว่า Next Hop เป็น Link Local Address “FE80::A8BB:CCFF:FE00:2000” ไม่ใช่ IPv6 Address ของ R2 E0/0 “2001:1:0:12::2” นั้นคือจุดที่แตกต่างจาก OSPFv2 ที่เรา Configure สำหรับ IPv4 เพราะใน Next Hop ของ OSPFv2 จะเป็น IPv4 Address ที่ Configure บน Interface ของ Router Next Hop

R1(config-if)#do sh ipv6 route        
IPv6 Routing Table - default - 5 entries
-----ตัดบางส่วน--------------------------------
LC  2001:1:0:1::1/128 [0/0]
     via Loopback0, receive
O   2001:1:0:2::2/128 [110/10]
     via FE80::A8BB:CCFF:FE00:2000, Ethernet0/0
C   2001:1:0:12::/64 [0/0]
     via Ethernet0/0, directly connected
L   2001:1:0:12::1/128 [0/0]
     via Ethernet0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive
R1(config-if)#
R1(config-if)# 


Check IPv6 Routing Table ของ OSPF บน R1 โดยใช้ Option “ospf” เพื่อกรองเอาเฉพาะ OSPFv3 Routes ทำให้ Check OSPFv3 Routes ได้สะดวกรวดเร็วขึ้น

R1(config-if)#do sh ipv6 route ospf
IPv6 Routing Table - default - 5 entries
-----ตัดบางส่วน--------------------------------
O   2001:1:0:2::2/128 [110/10]
     via FE80::A8BB:CCFF:FE00:2000, Ethernet0/0
R1(config-if)#
R1(config-if)# 


Ping ไปที่ R2 Loopback0 บน R1 เพื่อ Check IPv6 Reachability หลังการ Configure และ Verify OSPFv3 Routing

R1(config-if)#do ping 2001:1:0:2::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:0:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1(config-if)# 


Check OSPFv3 Neighbor บน R2 เพื่อ Ensure ว่า R2 สามารถ Form OSPF Neighbor กับ R1

R2(config-if)#do sh ipv6 ospf neighbor

            OSPFv3 Router with ID (1.1.2.2) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
1.1.1.1           0   FULL/  -        00:00:34    3               Ethernet0/0
R2(config-if)#
R2(config-if)# 


Check OSPFv3 Database บน R2 พบ LSA ทั้งหมด 3 แบบ
1.Router Link States หรือ LSA Type 1 นั้นเอง
2.Link (Type-8) Link States (Link LSA หรือ LSA Type-8)
3.Intra Area Prefix Link States (Intra-Area Prefix LSA หรือ LSA Type-9)

R2(config-if)#do sh ipv6 ospf database

            OSPFv3 Router with ID (1.1.2.2) (Process ID 1)

        Router Link States (Area 0)

ADV Router       Age         Seq#        Fragment ID  Link count  Bits
 1.1.1.1         1288        0x80000002  0            1           None
 1.1.2.2         1287        0x80000002  0            1           None

        Link (Type-8) Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Interface
 1.1.1.1         1572        0x80000001  3          Et0/0
 1.1.2.2         1293        0x80000001  3          Et0/0

        Intra Area Prefix Link States (Area 0)

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID
 1.1.1.1         10          0x80000006  0          0x2001      0
 1.1.2.2         416         0x80000004  0          0x2001      0
R2(config-if)#
R2(config-if)# 


Check IPv6 Routing Table บน R2 พบ OSPF Route ของ R1 Loopback0 (“O” คือ OSPF Intra Area Route ที่อยู่ภายใน Area 0 นั้นเอง)

R2(config-if)#do sh ipv6 route        
IPv6 Routing Table - default - 8 entries
-----ตัดบางส่วน--------------------------------
O   2001:1:0:1::1/128 [110/10]
     via FE80::A8BB:CCFF:FE00:1000, Ethernet0/0
LC  2001:1:0:2::2/128 [0/0]
     via Loopback0, receive
C   2001:1:0:12::/64 [0/0]
     via Ethernet0/0, directly connected
L   2001:1:0:12::2/128 [0/0]
     via Ethernet0/0, receive
C   2001:1:0:23::/64 [0/0]
     via Ethernet0/1, directly connected
L   2001:1:0:23::2/128 [0/0]
     via Ethernet0/1, receive
L   FF00::/8 [0/0]
     via Null0, receive
R2(config-if)#
R2(config-if)# 


Check IPv6 Routing Table ของ OSPF บน R2 โดยใช้ Option “ospf” เพื่อกรองเอาเฉพาะ OSPFv3 Routes ทำให้ Check OSPFv3 Routes ได้สะดวกรวดเร็วขึ้น

R2(config-if)#do sh ipv6 route ospf
IPv6 Routing Table - default - 8 entries
-----ตัดบางส่วน--------------------------------
O   2001:1:0:1::1/128 [110/10]
     via FE80::A8BB:CCFF:FE00:1000, Ethernet0/0
R2(config-if)#
R2(config-if)# 


Ping ไปที่ R1 Loopback0 บน R2 เพื่อ Check IPv6 Reachability หลังการ Configure และ Verify OSPFv3 Routing

R2(config-if)#do ping 2001:1:0:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:0:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R2(config-if)# 

 

ทดสอบตัวอย่างให้เห็นภาพของ OSPFv3 มาค่อนข้างยาวนะครับ แต่อย่างน้อยถ้าท่านไหนอ่านมาถึงจุดนี้ก็คิดว่าจะพอมองเห็นภาพ OSPFv3 ขึ้นมาบ้างแล้วนะครับ

แล้วอย่าลืมไปกด  Like page Ninehua.com เพื่อจะได้ติดตามข่าวสารและแชร์คู่มือต่างๆ ของ นายหัว.คอม นะครับ